	Gantt Chart & Timeline Center
HOW TO DRAW GANTT CHARTS

	[image: image1.png]




	
What are Gantt Charts?

	Gantt charts are bar graphs that help plan and monitor project development or resource allocation on a horizontal time scale. 
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	Typically, Gantt charts indicate the exact duration of specific tasks, but they can also be used to indicate the relationship between tasks, planned and actual completion dates, cost of each task, the person or persons responsible for each task, and the milestones in a project's development. 
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	Gantt charts are also used by supervisors and team leaders to schedule team members for various time dependent tasks such as visiting client companies for a sales organization or guard duty for the military. They can also show the activity load of departments or machines. 
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	Basic Gantt Chart Shapes

	The basic shapes required to make a Gantt chart include tables, Gantt bars, milestone markers, and link lines. 
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Gantt bars indicate the duration of tasks. 
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Milestone markers signal a major turning point in the project such an approval meeting or the release of a product. They can also mark the beginning and end of tasks. 
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Links lines show the relationship between two tasks, often indicating that a task can only begin when another ends. 
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SmartDraw is designed to help you draw Gantt charts quickly and easily. Since the underlying shape of a Gantt chart is a table, you should start by creating a table. 

	

	Tables

	You can create a new table by clicking on the Table button on the toolbar or by picking Add New Table from the Table menu. 

	

	[image: image9.png];
e ] e
ja(@)(ais]]v]|=](s] mm

Add a new table using the

Table button on the toolbar ol Backgroumd Color

blE!

ol Background Shadng

] Cilneste
Grilie Gol,

Add a new table
using the Table menu

e





	

	Formatting Your Table

	You can set the number of rows and columns in your table with the Format Table command under the Table menu. (SmartDraw will present this dialog box when you create your new table.) You can also choose from a list of ready-made table formats. 
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	After creating the table, if you need to add or delete rows or columns, just select the appropriate area in your table and choosing Insert Cells or Delete Cells in the Table menu. You can select and entire row or column by moving your cursor to the table's edge until you see a thick, black arrow, as shown below, and then clicking once. 
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Selecting an entire table column 

	

	To avoid problems later on, you should finalize the number of columns and rows in your table before you lay any images on top of it or before you join and split cells. 

	

	Joining and Splitting Cells

	Once you have finalized the number of rows and columns in your table, you can join and split cells to create the look you want. To join cells into one larger cell, select the table cells you want to join, go to the Table menu, and choose Join Cells. To split a cell into two equal-size cells, choose the Split Cells command in the Table menu. 
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	After the Join Cells operation above, the table looks like this: 
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	You can keep joining and splitting cells until you find the format that suits your needs. 
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Adding Color to your Gantt Table

	Each cell in your table can have a unique background color (and it can also hold text). To change the background color of a cell or a group of cells, select the cells with your mouse, right-click, and select Cell Background Color from the pop-up menu. 
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	Border and Grid Styles

	You can change the grid and border style of any table, or of selected cells. To change the border thickness of the entire table, make sure your table is selected (click on the outermost border), go to the Shapes menu, and select the appropriate line thickness from the Border Thickness sub-menu. 

	

	[image: image16.png]Shapes Lines Table Text Armange Tools Li

Fil Color IR

Shading »

Nore
Border Style Harine.
Border Color

Shape

Text Entry Properties,
Shape Properties

Edit Shape Outlne
Connection Paints,






	

	From the same Shapes menu, you can also specify a dashed or solid border type. 
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	To change the border color, select a color from the palette under the Border Color command. 
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	You can also change the style of the borders of individual cells (or groups of cells) in your table. Just select a cell or group of cells, then right-click on the selected area, and choose Grid Line Style, Grid Line Thickness, or Grid Line Color from the pop-up menu. 
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	If you select None from the Grid Line Thickness sub-menu, your chosen grid lines will become invisible. To edit only one specific grid line, move your cursor over the grid line until your cursor changes to the Grid Line Selection Cursor. Click on the grid line to select it. Then right-click to bring up a pop-up menu, and choose either Grid Line Style, Grid Line Thickness, or Grid Line Color to customize the line. 
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Formatting Gantt Chart Rows and Columns

	You can customize the height or width of any individual row or column by simply dragging the grid lines to their desired position. 
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Dragging a grid line to change the height of a row 

	

	Adding Text to Your Gantt Chart

	To add text to any cell, click once inside the cell. When you see the text editing cursor, you can simply start typing. If you type more text than will fit in the cell, SmartDraw will allow the text to shrink to a set size before increasing the size of the cell to accommodate your growing text. 
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To add text to any cell, click once inside the cell

	

	To customize how small your text can shrink, make sure the table is selected, go to the Shapes menu, and choose Text Entry Properties. Here, you can specify the minimum size your text can shrink to, and you can tell SmartDraw how to grow your cells in order to accommodate larger text. 
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Change a cell's text entry properties in the Shapes menu

	

	Sometimes you may want to protect your text from editing, particularly if you share your Gantt charts with other people. You can allow or prevent text editing on a cell-by-cell basis using the Do Not Allow Text Editing command under the Table menu or, if you want to apply it to the whole table, you can select the Do Not Allow Text Editing option in the Text Entry Properties dialog box. 

	

	Text Style

	You can center or justify text within a cell, as well as change its font and size. Just highlight the desired cell or cells and choose from the options in the Text menu or from the Text buttons on the toolbar. 
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The toolbar offers quick and easy text editing

	

	The text buttons on the toolbar make it easier to make some simple style changes to your text without having to go to a menu. The Text menu offers more formatting options including changing the font and alignment, and inserting bullets. 
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Change fonts using the Text menu

	

	To change the alignment of text within a cell, select the cell, then go to the Text menu and choose from the array of alignment options. 
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Change text alignment in the Text menu
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Gantt Symbol Libraries

	Once your table is laid out, you can start adding task bars and milestone markers. The Gantt Symbol libraries contain ready-made milestone markers and task bars that you can stretch to indicate the duration of tasks. 
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One of SmartDraw's Gantt chart symbol libraries 

	

	With certain templates, the Gantt Symbol library might already be docked in the toolbar. If you want to add the Gantt Symbols to your toolbar, you can drag the library window over the toolbar and drop it into place. This way you can access the symbols without the library blocking your view of the work area. 
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A docked Gantt symbol library

	

	Finding the Libraries and Templates

	You can find the Gantt templates and the symbol libraries in your SmartDraw explorer. Open the SmartDraw tree to Timelines and double-click on the library or template you want to use. 
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You can find the Gantt libraries and templates under the Timelines folder

	

	Adding Task Bars to Your Gantt Chart

	To add a task bar to your Gantt chart, click on the bar's button in your Gantt library window (or on the docked Toolbar) and drag the bar into your table. Your bar will lie on top of your table, not actually inside the cells. 
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Dragging a task bar from a library into your Gantt chart

	

	The ready-made Gantt bars are designed to stretch horizontally. After you have dropped the bar on your table, select it, move your cursor to its edge until you see the resizing cursor (a horizontal two-headed arrow), then click on the bar and drag it to the desired length. 
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Stretching a task bar to show duration

	

	If you want to resize your Gantt bar not just horizontally but vertically,you can change the bar's properties in the Shapes menu under Shape Properties. 
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	Arranging Your Task Bars

	SmartDraw helps keep your shapes aligned by snapping them to an invisible grid that lies behind the drawing area. You can turn this snap feature on and off in the Arrange menu. For finer adjustments in position, use the arrow keys to nudge objects around 1 pixel at a time. To select the objects you want to arrange, click on each object in turn while holding down the shift key. This way you can move the selected objects as a group. 
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Moving objects as a group 

	

	Anytime you select more than one object in SmartDraw, the last object you select will become the target object (distinguished by black handles). When you choose to align objects or make objects the same size, all other selected objects will align and conform to the target object. 
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	To make the selected bars the same size as the target bar, go to the Arrange menu and select Make Same Size. 
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Making your Gantt bars the same size as the target bar 

	

	To align your bars to the target bar, go to the Arrange menu and select Align. 
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Aligning the Gantt bars to the target bar's left side 
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Linking Task Bars to Show Relationships

	To show the relationship between two task bars, you can connect them with a link line. There are some pre-made link lines in the Gantt symbol libraries, but you can also use the line tools available to you in SmartDraw. Make sure that in the Arrange menu your settings include Allow Lines to Link, Allow Shapes to Link, and Allow Shapes to Link to Lines. 
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	To connect two shapes with a line, click on one of the line tools in the toolbar [image: image41.png]pa'a it



and release. Now your cursor looks like a pencil. Touch the pencil to the edge of one shape and click down with the mouse (you'll see black dots on the edge of the shape). Drag the pencil to the edge of another shape, and release it when the cursor turns into an Anchor Symbol. 
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Linking two Gantt bars 

	

	The black dots are Connection Points. These points mark the places where a shape can be attached to a line or another shape. When you see Connection Points, you know your shape is ready to be attached to something. The Anchor Symbol appears when a line is anchored to the edge a shape. Once connected, lines and shapes stay connected, even if they are moved or stretched. 
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Connected Gantt bars stay connected, even if one is moved or stretched

	

	The pre-made linking-line symbols work just like the line tools in SmartDraw. Drag them out of the library and stretch them to connect any two bars. 

	

	Table cells vs. Gantt bars

	The ready-made Gantt bars lie on top of the table, not inside its cells. If you insert new rows or stretch the table, the Gantt bars will not move with the table. You will have to move them manually (this is why it's best to finalize your table design before adding task bars).

But you can avoid this problem by creating a different type of Gantt chart that uses colored table cells instead of floating Gantt bars. If you move, stretch, or redesign your table, the colored cells will move with it. 
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An alternate style of Gantt chart uses colored table cells for bars

	

	Annotating your Chart

	Include a legend below your chart (or on a separate page) explaining the colors of the bars and the meaning of any milestone markers. 
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Use a legend to annotate your chart 
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Tips for Effective Gantt Charts

	1) Make your Gantt chart easy to read by color coding your task bars. For example, if all the marketing tasks are blue and all the production tasks are red, it will be easier to identify department responsibilities at a glance. 

	

	2) Keep your Gantt chart concise by excluding trivial sub-steps. If a task needs to be analyzed in greater detail, create a second Gantt chart and hyperlink to it from the main chart. You can do this by selecting the object you want to link from and choosing Hyperlink to Another File from the Tools menu. Once the object is hyperlinked, a small plus sign will appear on its upper right hand corner. 
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The task bar for Task C is linked with another SmartDraw file or a web page. 

	

	3) Give a copy of the Gantt Chart to each team member and review responsibilities and milestones. To preserve your formatting and text as your chart passes from person to person, you can turn off the text editing property in the Table menu or under the Shapes menu. 

	

	4) Update the chart periodically to reflect the realities of your ongoing project. You can draw a vertical line down your Gantt chart to indicate the present time and identify which tasks are ahead of schedule and which tasks are behind schedule. 
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This review bar shows that Task B is behind schedule. 

	

	5) Create a polished chart by adding shadows and your company logo. You can choose from a number of ready-made styles in the Edit menu under Colors and Shadows, or you can create your own. You can import your company logo in a number of popular graphical formats and place it on your chart for a professional-looking result. 
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	6) Share your Gantt chart with others using the web. With one click, you can publish your chart to your FREE SmartDrawNet web space and share it with your colleagues. Any hyperlinks in your chart become working hyperlinks on the web—and interlinked pages become interlinked web sites!

You can also export your Gantt chart as a JPEG or a GIF image for the web, or you can save your chart as an HTML document (with working hyperlinks) and publish it on an Intranet or over the World Wide Web. 

	

	7) Create a professional presentation using SmartDraw and PowerPoint. You can copy/paste your drawing into any of the programs in the Microsoft Office Suite. 

If you paste your chart into another program (such as PowerPoint), you can edit it by simply double-clicking on the chart in the other program. This automatically opens the chart in SmartDraw for editing, and your changes will be updated in the other program. More info 

	

	This concludes the Gantt charts and timelines tutorial.
To see cool examples of Gantt charts and other timelines, click here.
For informational web sites and books on Gantt charts and project management, click here. 
Click here to return to the Gantt chart tutorial home page. 











