1 Select the Pgint Bucket tool.

More drawing tools and techniques

3 From the Colors section of the Tools panel, click on the second

Here are the rest of the main drawing tools and techniques. There will be @ Sta.ying stra.ight ) : colour swatch (see right).
an exercise at the end that will require all of the following skills. Shift-dr awing with : 4 Click to choose a new colour. That will set the Paint Bucket to
the pencil tool keeps : that colour
. . . . the line horizontal or : ‘
Coloured lines with the Pencil and Line tools vertical, ' 5 Click inside the shape to fill the shape with the new colour.

To draw lines in Flash, use the Pencil and Line tools.

The Pencil tool has three Options associated with it (see right).
Those options are at the bottom of the Tools window when the
Penciltool is selected.

Using the Ink Bottle tool

The Ink Bottle tool is used to apply different Stroke colours,
thicknesses and styles to objects. To change the Stroke of any shape:

1 Make sure the shape is not selected.
2 Select the Ink Bottle tool.

3 Using the Properties window (see below), click the colour swatch to choose a new @ Hairlines

stroke colour, That will set the Ink Bottle tool to that colour., Make your Strokes
as fine as you wish.
Flash will always

make them at least

+  Straighten tries to straighten the lines you draw,

+  Smooth tries to smooth the lines you draw.

»  Inkreproduces the line exactly the way you draw it.

The Line tool is very similar to the Pencil tool—except it only
draws straight lines. If Sunap fo Objects is selected (View > Snapping

(& Prapertios x | Fitters. | Parameters:)

> Snap to Objects) the Line tool will snap to a horizontal or vertical * :':;ﬁmﬂ : e one pixel wide,
line or onto another object. S 8 Do so they’ll always
be visible.

To change the colour of a line, look at the Colors section of the
Tools panel (see right}. Choose a stroke colour by clicking on the
colour swatch next to the pencil icon. Any lines drawn will now
have that colour.

Cofour  Stroke thickness Strake style

4 Typea number to set the thickness of the stroke, in pixels.

5 Select a Stroke style from the drop-down list.

Pamtmg with the Brush tool ¢ Click anywhere on the shape to outline the shape with the new stroke settfngs.

The Brush tool has size and shape Options (see below right). Choose a Brush size and e :
Shape from these two pop-up menus. - Sampling with the Eyedropper tool
You can also select from five Brush modes—this affects how the Brush paints on the - The Epedropper tool is used to sample (copy) fill and stroke settings of other shapes.

. =
Stage. The modes are: - To use the Eyedropper took:
«  Paint Normal will paint over everything like a normal J@ Paint Normal ® 1 Select the Eyedropper tool.

. h _
paintbrus © Paint fills @ 2 To sample another shape’s Stroke settings, click on the outline.
»  Paint Fills will paint only the fill (inside) of an object. | €2 Paint Behind @ Brush size N , C
i Paint Selection 3 To sample another shape’s Fill settings, click inside the shape,
*  Paint Behind will only paint behind an object. L — . . .
Paint Inside @ ‘The Paint Bucket and Ink Bottle tools will be set to the new settings.
+  Paint Selection will only paint the selected areas of PE—— ' Brush shape
an object. - Creating new colour swatches
*  Paint Inside will only paint inside the object that you first clicked in. n To create a new, customised colour swatch: Pop-cut menu
Use the Properties window to set the Colorand Smoothin:g {see below). The'!arger the l 1 Choose Window > Color. : . -
smoothing value the more the Brush stroke will smooth itself out. Smoothing set to zero - ) ) ] ) <L . £ Swalches
means it will not smooth itself at all / 2 Use the sliders in the Color window to mix a ‘ Y [Sobd 73 '
: s new colour. )|
[ Propertics [ itérs | Parameters. | 7 1 Adjust the transparency using the Alpha slider. '
' B LT 4 Click the pop-out menu on the top right of the
: @' E”J S Color window and choose Add Swatch (see right),
- Smoathing: 30 | S ot

T P 5 Choose Window > Swatches to see the new swatch, [ Aloha: [Tooss | [-] #od6c2z |
i SE— You may have to scroll down to it (see far right). ]
Changing a shape’s Fill and Stroke colours
Often you will want to change the Fill and Stroke colours of a shape after you have drawn
it, You can quickly change the Stroke and Fill of objects using the Paint Bucket and Ink Sliders New swatches
Bottle tools. Alpha values

: In the Color Mixer panel you saw
Using the Paint Bucket tool ' the Alpha setting, This relates to
. . . ! : how transparent the colour is.
The Paint Bucket tool | €A |is used to apply fills to objects. : Solid colours have 100% Alpha and
. . 3 completely transparent objects have

To change the Fill colour of any shape: an Alpha of 0%,

1 Make sure the shape is not selected.
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(reating depth with gradients

Gradients are colours that change. Sometimes a light colour will become darker, - Nane
sometimes one colour will blend into another. There are unlimited possibilities ¥ Selid
with gradients.

There are two kinds of gradient— linear and radial. To apply
either of these to a shape, simply look in the bottom of the Swatches
window or any of the pop up colour palettes for the gradient
swatches (see below).

To create a new gradient with the Color window:

i

The new gradient swatch will add itself to the other swatches in the’

Bifmap . -

x| Eigad T8)

S N inedr RGE

Choose a gradient type. You have two choices; Linear or Radial.

The gradient appears with two small colour swatches. L Coloursiders

Either click on each swatch and set the colours for the gradient
using the colour sliders, or double-click to choose from the
Swatches window.

¥
™ Gradient colowr ©

To add extra swatches for multi-coloured gradients, click swratches

underneath the gradient bar.

Remove unwanted swatches by dragging them away from the

‘b Turn object snapping off
gradient bar.

While object snapping can be very
useful it can often be very annoying,
Choose View > Snapping > Snap to
Objects if it is causing problems.

When you are done, choose Add Swatch from the Color window’s
pop-up meni.

Swatches window and can be applied to objects.

Transforming applied gradients

To adjust the size and direction of a gradient applied to an object:

1

-

Focal point

Centre point

Choose the Gradient Transformation tool (which hides underneath Width
the Free Transform tool ) and click the gradient. Size
Rotate

Drag the Centre point, Focal point, Size, Width and Rotate control handies to
suit (see right).

‘@ Red building block

Follow these steps to build a red block. It is best to draw with hairline strokes that can
be filled with colour later:

1 Examine this graphic closely. You can see it is really just eight pairs of
ovals and a handful of straight lines.

?  Draw one small oval, then duplicate it by selecting it and Option/Alt-
dragging it.

3 Add straight lines where needed. You do not need to be precise. Later,
delete the parts of the stroke that you do not want. The finished stroke will have no
Ol (below—1).

4 Set the Paint Bucket tool to your chosen colour and fill the parts (below—2),
Your brick is now outlined and filled. This sketch-and-fill technique can be used to
create a wide assortment of shapes. : :

5 Set the Paint Bucket tool to a gradient
colour and experiment with shading
instead (right— 3). Clicking with the
Paint Bucket tool in slightly different _
parts of a shape will create slight
shading differences. J

12§ Ivmontcsion To Fuasn (53 Copyright © 2007 Natcolf Publishing

Storing symbols in the Library

A Flash movie may contain many dozens of graphics, making for a potentially large '
@ Library shortcut:

file size. However, many graphics are often repeated. You can keep your movies small
by turning repeated graphics into Symbols and storing them in the Library.

There are three types of symbol, but in this section just Movie clip and Graphic
symbols will be looked at.

Each Flash project has its own Library. Create a new file and open your Library now:
Window > Library. The Library will be empty at first.

(reating symbols

The easiest way to create a symbol is to draw the graphic on the Stage first, then turn it into
a symbol. Try it now—create a graphic and follow these steps:

1 Select all of the graphic on the Stage (make sure

You'll use the Library
so often that a good
shortcut is essential,
3£/ Crl-L calls up the
Library panel.

you select the Stroke, if you have one, as well as the

Fill) and choose Modify > Convert to Symbol...

7 Name: itea.cup

2 Inthe Convert to Symbol dialog box (see right),

T).Fl.llé','.:: O Mowe cﬁa.:':_. :
name the symbol (something logical and :

CEBAeN L e
: :_"':.@C.Riphic: L .' L

._ : Registration: §§§

(el )

2 {-Advaniced -}

recognisable) and set the Type to Movie clip or
Graphic. The difference between these two symbol
types is explained below.

3 Click OK. This graphic is now a symbol and stored in the Library.

Movie clip vs Graphic symbols
The difference between Movie clip and Graphic symbols is not particularly obvious.

Graphic symbols should be used for static images and simple pieces of animation only.

Graphic symbols cannot be scripted, cannot have 9-slice scaling applied to them, nor can
you add effects (drop shadows etc) to them,

Movie clips are the most complex and useful type of symbol. They are really mini-movies,
with timelines of their own, which play inside the main Timeline. In addition, movie clips
are scriptable with ActionScripi,

You will probably find it easier in the long run to create Movie clip symbols rather than

Graphic symbols, simply because they are more versatile.

Using the Library

When your Library contains a symbol, you can use this symbol many-times by dragging it

onto the Stage. Each time you place a symbol on the Stage, you create an instance of it.

1 Drag the symbol onto the Stage now to create an instance of the symbol. Do this
several times if you like.

2 Notice that the instances can be placed on top of each other without
cutting into each other or merging into one graphic.

Main Stage  Symbol currently being edited

The symbol in the Library is your master copy. Take care not to delete the

iibl Symbols ]

symbol in the Library. If this happens, all the instances will disappear too!

Editing symbols

Instances are linked directly to the master symbol stored in the Library.
If you modify a symbol, all the instances of that symbol change too.

The easiest way to edit a symbol is to double-click any instance on the
Stage. Follow these steps:

1 Double-click an instance of a symbol on the Stage.

2 Note that the Scerre Menu shows you that you have left the Stage and
are in symbol-editing mode (see right).

Copyright © 2007 Natcoll Publishirg
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3 Male any small change to the graphic. Importing 1ibrary items

4 Click on the words Scene 1 to return to the main Stuge. Entire libraries from other Flash files can be brought into your current movie. Any Flash

All instances, plus the symbol in the Library, will have changed. This shows how all file can be opened as a Library by choosing File > Import > Open External Library. Ttis a
instances are interconnected via the symbol. ' good idea to save a backup of your own file. If you ever delete a symbol from the Library
' by mistake, you can import your backup file as an External Library.

9-slice scaling

Normally Flash scales all parts of a graphic evenly, and sometimes this
even scaling can make parts of a graphic distort (see right).

Any External Library item used on the Stage automatically becomes part of your main
Library too.

ise
é(.

5@ Many effects from one symbol

9-slice scaling is a setting which allows you to apply scaling unevenly Original graphic
across a graphic (see right), This type of scaling only works with a
Movie clip symbol.

This exercise will show how the Library can be used to create relatively complex

To create a Movie clip with 9-slice scaling: effects with little work:

1 Create a graphic and convert it to a Movie clip symbol. 1 Create a cube using shapes filled with greyscale linear gradients. Transform

the shapes and the gradients so that it look somewhat 3-dimensional
(see right).

2 Expand the Symbol Properties box by clicking the Advanced button.,

3 At the bottom of the window, make sure Enable guides for 9-slice
scaling is checked on (see right). ? Turn the shape into a Movie clip syinbol and make sure that 9-slice scaling

1s switched on.

This and other symbol properties (including its Type) can be
edited later by Control/right-clicking on a symbol in the Library and
choosing Properties... from the drop-down menu.

3 Edit the 9-slice guides so that when the cube is stretched it will just get
taller and not distort (see right).

4 Drag and drop the symbol several times on the Stage to create instances. R -

5 Use the Free Transform tool to make some instances shorter and
some taller.

! To edit the guides for 9-slice scaling, double-click on an instance of
the symbol on the Stage or on the instance itself in the Library. You
will see the guides (below) which can be moved by dragging them.
The corners of these guides are the parts which are never scaled,

6 Click on one of the instances and look at the Properties window. Find the
setting in there labelled Color and change it from None to Tint (see below).

ipark for ACtIONScrpt.
Expart for reitlmi shirin
gt b first frani 7w

E bmpart For nuntime

'

'

|

Color settings
1

1= Praperties x

! Movie: Clip

iy uidaie bafore pibligh

® Enable guidei for ‘Bgtice scal

' Eﬂend Normal- - - ! !}3

- [T usé runtime hitmap cachiing .

[
Enable 9-slice quides

Filters
Flash allows you to add a limited number of live filters to Movie clip symbols; filters like 7 Experiment with the tint settings to colour some of the instances. )
drop shadows, blurs and glows. These filters can be edited and updated and can also be & Apply some filters to some of the cubes—the ones shown below have a mixture of
adding to animated elements. Filkers pane i the Blur and Drop Shadow filters applied.
]
To apply a filter to a Movie dlip: Notice the flexibility that you
o . Add filter have with instances. You can
1 Crf.:ate a Movie clip symbol and select an instance distort their shape, change
of it on the Stage. their colour and add filters
2 In the Properties window, switch to the Filters while they are still part of the
pane (see right). same symbol.
3 Using the Add filter button, choose a filter.
4 Adjust the settings for that filter until you see the : _.
effect you want (see below). U Cradient Clow. : -
These filters can be copy-pasted from one instance 3 _?Fﬁqi?:‘_ ?f".e.i. :

10 another using the copy and paste buttons in the
Filters pane of the Properties window (see below).

Copyfilters  Paste filters
i

[Peoperts £ {
FREN. S

; e D]'nrier"s_ﬁa_'déﬁv__' v
45 [z] O vide objeéce -
Distance: 5[] .

i - Strength: |
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~OREST HILL COLLEGE
?-SOURCE CENTRE

+ To change the width of a text box, click in it with Clickand drag here to resize text box
the Text tool and then drag the handle in the top
right corner to resize it (see right). ( e k qQ; \ qQ

* You can change the colour of text, but you can’t C t I ‘
apply a gradient or bitmap fill o it. Likewise you |
can’t add a stroke to text. To do either of these
things you first need to break apart the text (Modify > Break
Apart) twice, the first time into individual letters and the second

time into outlines which can then have any Stroke or Fill attribute
applied to it (see right). '

Tiling with bitmaps

One small bitmap can be used to fill large areas in Flash, or be used to paint with, asa
repeating pattern on a brush, To do this, follow these steps:

["Calor | Swatthes.

1 TImport a graphic into your project’s Library.

2 Select one of the shape tools or the Paintbrush tool.

3 In the Color window, change the fill Type from Solid to Bitmap. Any bitmaps imported |’
into your project will be available to use as a fill. Sclect the bitmap that you want to
use (see right).

4 The bitmap is now your Fill colour. Painting or making shapes with this setting will

i — Note the anti-alias settings in the Properties window (see previous
use the bitmap as the fil. Altering the bitmap fill using the Gradient Transform tool : & P (scep

page). Anti-aliasing attempts to smooth out the edges of objects,
and is particularly important for text because too much anti-aliasing
and text can become quite hard to read. Always choose a setting
appropriate to your use of text.

Edges Edges

No-anti-aliasing Anti-afiasing applied

. £ .
5 Use the Gradient Transform tool you can resize, skew,
stretch and rotate the fill (see right).
‘The pattern will repeat automatically.

Turning bitmaps into vectors

The Trace Bitmap command will convert a bitmap into a vector
graphic with editable areas of colour.

1 Select a bitmap on the Stage. Make sure it is just a bitmap and
not a symbol.
2 Choose Modify > Bitmap > Trace Bitmap.

1 3 Enter a Color Threshold value. This defines how similar
colours must be, to be considered the same. A higher
number means fewer colours.

t1
&
&

‘D Import and trace a logo

Choose a favourite logo, perhaps from the web, and prepare to turn it into an all-
vector file by tracing the bitmap. Your challenge is to keep the logo looking good,
while reducing the file size as much as possible.

4 Enter a value for Minimum Area. This will define how
many surrounding pixels will also be selected.

s UG i E T

; Cornér threshold:. £-Normal -+

i . . ( Préview )
"[-1 5 Enter a value for Curve Fit to determine how smoothly S
outlines are drawn.

1 Create a new blank file and save it with a sensible and recognisable name,
Don't forget to make sure it has a .fla file extension.

Hs 6 Enter a value for Corner Threshold to determine whether the corners are sharp @ Flesizeb ‘ 2 Importalogo to the Stage. This example uses a fictitious logo for the .
i: or smooth. tie size heware: : company ‘Buzz’s Coffee’.
! _ _ The file size of th ) . . .
i 7 The Preview button allows you to see the effect on your bitmap before you . aze 4 if:if a(;)a Ca; : 3 Double-click on the bitmap in the Library, uncheck Use document default
i comumit to it, exceed the file size ; quality, choose a Quality setting and click the Tesrbutton. Make a pencil note
of the original if the of its compressed size.
i ted bit .
) iincli) c:)':rqflex ;:éagle : 4 Tmc.e the bitmap. Make a note on paper of the
USlng text tracing is precise. settings you apply. Preview the results.
5 If the result is not good enough, modify the
The Text tool ssettmgs and try again. In the examl?le on the
right the Color Threshold was too high (300)
You add text to your Flash movies using the Text tool. ‘ _ and Minimum Area to0 high (20 pixels).
As with all other tools the Text tool works together with the Property @ Fonts 7 ;_ ¢ You might also choose to tidy up or recreate
Inspector (see below). When you use Static Text, any some parts in Flash. In the example on the
+ To add text to the Stage you can cither just click and type, which adds text fb(;n;ig‘; ;;:éi 1‘:; ]tli g;omngf}' ‘ E far right, the text is static text in a Movie clip
of an infinite length, or drag the text tool o define a specific width for However, fonts aren’t included in symbol with some Flash filters applied.
your text. Text automatically wraps to the next line as text fills the box. the .fla authoring file, so if you : 7 When you have a result that you like, save the
+  Make sure that basic text you add is set as Static Text. This is the most work on more than one computer ; file and test the movie by pressing 3/Ctrl-
. . . . ) you will need the same fonts : B Thi b-ready Shock
basic type of text. You will use Dynamic Text in later exercises. installed on each machine. fiter. This creates a web-ready shockwave
{.swf} version of your Flash movie,

+  Move text blocks around

Text type
by using the Selection i

8 Choose View > Bandwidth Profiler. Look in the top right for the movie’s size, See if
your vector version is smaller than the bitmap version would have been.

tool, To edit text again, e Properties X {Rlters:}-

you can either double- [

fao v} (]

) L Anti-allas for readabllity

' H . - . -
SEE T s 9 Close the Shockwave movie. i you managed to make a file size saving while

click c.m the text W.lﬁl the |- e e e W B . & mito ke e:ca m‘ng the quality o.f the 1mage, you have completed this task. If not, try again
Selection tool or clickon | & W VT B : o o with different Trace Bitmap settings.
. * - SRl - E L L E
it with the Text tool. ' — : \ ./
Anti-alias settings :
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Scrolling text

The UlScrollBar component
A seemingly simple thing like adding a scroll bar to a block of text in Flash is surprisingly

complicated. However, the last few versions of Flash have all included some pre-built, pre-

scripted objects called Components. Most of them are used for building complex Flash
applications, but there is one which is commonly used at a basic level; the UIScrollBar.

To use this component, do the following:

1

Kse

Create a text box with a fairly large amount of text in it. There has to be enough text to

warrant a scroll bar!

Text type

Instance name
1

Change the text type to Dynanric Text (see
right}. Dynamic text can be controlled by
ActionScript {in-built into the component).

Give the text box an Instance name (see right). e
This should have no spaces in it (- and _

s Propertics >< [ Fiters | Faramate

- & Dynaale Text

characters are OK though).

Set the Line type to Multiline, {see above)
otherwise your text box will only display a single line!

Line type

Make sure the anti-aliasing is set to Anti-alias for readability.

Using the Selection tool, resize the text box so that it’s shorter than its contents (so

that some of the contents are hidden).

Open the Components window and in the User Inferface folder find the UlSeroliBar
(see right). Drag and drop it onto your dynamic text box. The component should
snap to the height of the text box and you will see it {and a folder of associated parts)

appear in your Library.

Test your movie (38/ Ctrl-Enter) by creating

a .swf file. You will only see the scroll bar
working in Flash Player, not in the authoring
environment itself.

To add edges to your text box, you can
cither add some graphics in the normal way

to create a border, or use the Show border

win the races tomorrow; it told me who
would be the next prime minister; it told me
what the weather would bs ke in two years
time. Imagine that! A predicting pepert It was
quite geod a1 il too, eveything it predicted ;
for the first week cama true, exactly ag it had |
daseribed.

But than came my ditemma. On page 22 of
newspeper was a story abaut my next door
neighbour's cat being run cvar. Now I'm nat
one to try and change the way things happen
in life, but | happan to raally like Mr Tumnus.

around textbutton (see above) —-this will

not only show a border but will alse give the text box a white background.

Show border around text

- Libia

i Eamp:ullgnl.s >_r. e
U Progressias
@ AadloButtan :
%Y scroipane g
el Slider

{=] Textaren

[s5ll Fextinpur

TileList
E_EJ UlLoader

ided

FLVPlayback :
FLYPlaybackCaptioning: -
0 BackButon :

&% BufferingBar

&) CagrionBution

v,

R

5@ Create a text layout

Using what you have learned about text so far, create a layout which uses several

different types of text. Tty the following:
»  Create Static Text headings

+  Create a scrolling text box for a large amount of text
(change the text type to Dynamic Texd).

* Try applying some filters to the heading text: filters
can be applied directly to text—you don’t need to
make it into a Movie clip first.

+  Break apart some text and try applying gradient or
bitmap fills and strokes to the letters.

*  Add borders or other graphics to your scrolling text
and to the rest of the movie.

Dor’'t forget to save your movie and test it by turning it

into a .swi file.
.
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